import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\(\\s*((?:const\\s+)?(?:u?(?:byte|int)\\d*|void)(?:\\s*\\*)?)\\s*\\)\\s*(\\w+(?:\\((?>[^()]+|(?<c>)\\(|(?<-c>)\\))*\\))?)";
final String string = "#Pass 1\n"
+ "(void)memcpy(&a[0],(void * )hihi, (UBYTE) V_SIZE);\n"
+ "(void) memcpy((VOID*)abc, (const VOID*) dafa, (uint8)NUMBER_SIZE);\n"
+ "(void )memcpy(\n"
+ " (void *)p,\n"
+ " &abc, (uint8)DATE_SIZE);\n"
+ "#Pass 2\n"
+ "static_cast<void>(memcpy(&a[0],(void * )hihi, (UBYTE) V_SIZE));\n"
+ "static_cast<void>(memcpy((VOID*)abc, (const VOID*) dafa, (uint8)NUMBER_SIZE));\n"
+ "static_cast<void>(memcpy(\n"
+ " (void *)p,\n"
+ " &abc, (uint8)DATE_SIZE));";
final String subst = "static_cast<$1>($2)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}