# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)\(\s*((?:const\s+)?(?:u?(?:byte|int)\d*|void)(?:\s*\*)?)\s*\)\s*(\w+(?:\((?>[^()]+|(?<c>)\(|(?<-c>)\))*\))?)"
test_str = ("#Pass 1\n"
"(void)memcpy(&a[0],(void * )hihi, (UBYTE) V_SIZE);\n"
"(void) memcpy((VOID*)abc, (const VOID*) dafa, (uint8)NUMBER_SIZE);\n"
"(void )memcpy(\n"
" (void *)p,\n"
" &abc, (uint8)DATE_SIZE);\n"
"#Pass 2\n"
"static_cast<void>(memcpy(&a[0],(void * )hihi, (UBYTE) V_SIZE));\n"
"static_cast<void>(memcpy((VOID*)abc, (const VOID*) dafa, (uint8)NUMBER_SIZE));\n"
"static_cast<void>(memcpy(\n"
" (void *)p,\n"
" &abc, (uint8)DATE_SIZE));")
subst = "static_cast<$1>($2)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.