const regex = /^\+(?!3|80)\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+(?!3|80)\\d+$', 'gm')
const str = `+3899
+8044566
+790067
+35567
+567890
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}