$re = '/^\+(?!3|80)\d+$/m';
$str = '+3899
+8044566
+790067
+35567
+567890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);