import Foundation
let pattern = #"^.*\$inline\((.*)\)\$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ez itt egy teszt szöveg $inline(file(p)ath)$ és ) itt folytatódik a szöveg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)