using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=={)[\w\s\d]+|(?<==)[\w\d]+";
string input = @"переменная=lll
переменная={1ioioi ooi}
пере менная=898";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}