$re = '/(?<=={)[\w\s\d]+|(?<==)[\w\d]+/';
$str = 'переменная=lll
переменная={1ioioi ooi}
переменная=898';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);