re = /(?<timestamp>^.*?)\s(?<apic_host>.*?)\s%LOG_LOCAL(?<apic_facility_level>\d)-(?<apic_severity>\d)-SYSTEM_MSG\s\[(?<apic_code>.*?)\]\[(?<apic_lifecycle_state>.*?)\]\[(?<apic_rule>.*?)\]\[(?<apic_severity_text>.*?)\]\[(?<apic_DN_of_affected_MO>.*?)\]\s(?<apic_message>.*)$/m
str = '2023-02-27T13:55:00-06:00 apic-99 %LOG_LOCAL7-3-SYSTEM_MSG [F1298][raised][configuration-failed][minor][uni/epp/fv-[uni/TENANT/ap-APP/epg-Dealer-Server]/node-1105/polDelSt/fault-F1298] For tenant TENANT, application profile APP, deployment of application EPG Dealer-Server failed on node 1105. Reason Delivered,Node belongs to different POD
2023-02-27T13:55:00-06:00 apic-99 %LOG_LOCAL7-3-SYSTEM_MSG [F1298][raised][configuration-failed][minor][uni/epp/fv-[uni/TENANT/ap-APP/epg-Dealer-Server]/node-1105/polDelSt/fault-F1298] For tenant TENANT, application profile APP, deployment of application EPG Dealer-Server failed on node 1105. Reason Delivered,Node belongs to different POD
2023-02-27T13:55:03-06:00 apic-99 %LOG_LOCAL7-2-SYSTEM_MSG [F0321][soaking][unhealthy][critical][topology/pod-2/node-3/av/node-4/fault-F0321] Controller 4 is unhealthy because: Data Layer Partially Diverged
2023-02-27T13:55:03-06:00 apic-21 %LOG_LOCAL7-2-SYSTEM_MSG [F0321][soaking_clearing][unhealthy][critical][topology/pod-2/node-3/av/node-4/fault-F0321] Controller 4 is unhealthy because: Data Layer Partially Diverged
'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end