import Foundation
let pattern = #"(?<timestamp>^.*?)\s(?<apic_host>.*?)\s%LOG_LOCAL(?<apic_facility_level>\d)-(?<apic_severity>\d)-SYSTEM_MSG\s\[(?<apic_code>.*?)\]\[(?<apic_lifecycle_state>.*?)\]\[(?<apic_rule>.*?)\]\[(?<apic_severity_text>.*?)\]\[(?<apic_DN_of_affected_MO>.*?)\]\s(?<apic_message>.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2023-02-27T13:55:00-06:00 apic-99 %LOG_LOCAL7-3-SYSTEM_MSG [F1298][raised][configuration-failed][minor][uni/epp/fv-[uni/TENANT/ap-APP/epg-Dealer-Server]/node-1105/polDelSt/fault-F1298] For tenant TENANT, application profile APP, deployment of application EPG Dealer-Server failed on node 1105. Reason Delivered,Node belongs to different POD
2023-02-27T13:55:00-06:00 apic-99 %LOG_LOCAL7-3-SYSTEM_MSG [F1298][raised][configuration-failed][minor][uni/epp/fv-[uni/TENANT/ap-APP/epg-Dealer-Server]/node-1105/polDelSt/fault-F1298] For tenant TENANT, application profile APP, deployment of application EPG Dealer-Server failed on node 1105. Reason Delivered,Node belongs to different POD
2023-02-27T13:55:03-06:00 apic-99 %LOG_LOCAL7-2-SYSTEM_MSG [F0321][soaking][unhealthy][critical][topology/pod-2/node-3/av/node-4/fault-F0321] Controller 4 is unhealthy because: Data Layer Partially Diverged
2023-02-27T13:55:03-06:00 apic-21 %LOG_LOCAL7-2-SYSTEM_MSG [F0321][soaking_clearing][unhealthy][critical][topology/pod-2/node-3/av/node-4/fault-F0321] Controller 4 is unhealthy because: Data Layer Partially Diverged
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)