package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^A\d{3}[a-z]$`)
var str = `A234r
B234a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}