$re = '/^A\d{3}[a-z]$/';
$str = 'A234r
B234a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);