import re
regex = re.compile(r"^(?:http:\/\/|https:\/\/)?(?:www\.)?(?:imdb.com\/title\/)?(tt[0-9]*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("http://www.imdb.com/title/tt2488496/?ref_=nv_sr_1\n"
"http://www.imdb.com/title/tt2488496/\n"
"https://www.imdb.com/title/tt2488496\n"
"imdb.com/title/tt2488496\n"
"tt2488496\n"
"imdb.com/title/season2488496\n"
"http://www.imdb.com/title/tt2488496\n"
"http://www.imdb.com/news/ni59315274\n"
"www.imdb.com/title/tt2488496/?ref_=nv_sr_1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")