#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Debug.*?endmsg|(restart-required)"
Local $sString = "Debug: testing message with no restart-required.endmsg.Warn:garbagestuff.Debug: another message.endmsg.Warn:moregarbage.Debug: this testing message has restart-required.endmsg.Error:server 404 not found.Critical restart-required. Debug: blah blah restart-required.endmsg."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)