re = /Debug.*?endmsg|(restart-required)/m
str = 'Debug: testing message with no restart-required.endmsg.Warn:garbagestuff.Debug: another message.endmsg.Warn:moregarbage.Debug: this testing message has restart-required.endmsg.Error:server 404 not found.Critical restart-required. Debug: blah blah restart-required.endmsg.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result