$re = '/^(?!.*\/john\/doe\/).*TRUE[^\/]*\.jar$/';
$str = '/aa/john/oe/xx/yy/xxTRUEyy.jar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);