re = /^(?!.*\/john\/doe\/).*TRUE[^\/]*\.jar$/
str = '/aa/john/oe/xx/yy/xxTRUEyy.jar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end