use strict;
my $str = 'a';
my $regex = qr/[^\p{L}]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";