const regex = /.??*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.??*', '')
const str = `.bashprompt
toto
.`;
const subst = `\1/\2/\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);