import re
regex = re.compile(r".??*")
test_str = (".bashprompt\n"
"toto\n"
".")
subst = "\\1/\\2/\\3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)