#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:(?:.*?\|\s?){6}.*::)(.+?)(?:(?=\.?\s?$)|(?=\s?\.?\|))"
Local $sString = "[String1] | [String two is here] ||| String 3 | String-4 | String::5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")