package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i) (\+[a-zA-Z0-9]+)`)
var str = `Lorem ipsum +dolor ++sit amet +gjhghh.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}