$re = '/ (\+[a-zA-Z0-9]+)/i';
$str = 'Lorem ipsum +dolor ++sit amet +gjhghh.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);