import re
regex = re.compile(r"^((http|ftp|https):\/\/)?([\w_-]+(?:(?:\.[\w_-]+)+))([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?", flags=re.MULTILINE)
test_str = ("www.stackoverflow\n"
"stackoverflow.com\n"
"www.stackoverflow.com\n"
"https://www.stackoverflow.com\n"
"ftp://fdffd.com\n"
"someone@stackoverflow.com\n"
"foo.bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")