re = /^((http|ftp|https):\/\/)?([\w_-]+(?:(?:\.[\w_-]+)+))([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?/m
str = 'www.stackoverflow
stackoverflow.com
www.stackoverflow.com
https://www.stackoverflow.com
ftp://fdffd.com
someone@stackoverflow.com
foo.bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end