using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(W\d{3}\.\d{2})(\.\d{2})?$";
string input = @"W100.01.01
W200.06";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}