$re = '/(W\d{3}\.\d{2})(\.\d{2})?$/m';
$str = 'W100.01.01
W200.06';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);