#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:File: '(?P<File>.*)')\s+(?:Size: (?P<Size>[\d]+)).*(?:IO Block: [\d\s]+(?P<Type>[\w ]+))\s+.*\s+(?:Access: (?P<Permissions>\([\w\/ \-]+\)))\s+(?:Uid: \(\s*[\d\s]+\/\s*(?P<User>[\w]+)\))\s+(?:Gid: \(\s*[\d]+\/\s*(?P<Group>[\w]+)\)).*\s+.*\s+.*\s+(?:Change: (?P<Change>[\w\- \:\.]+))\s+(?:Birth: (?P<Birth>[\w\- \:\.]+))"
Local $sString = " File: '/home/user/file.php'" & @CRLF & _
" Size: 23283 Blocks: 48 IO Block: 4096 regular file" & @CRLF & _
"Device: 801h/2049d Inode: 967703 Links: 1" & @CRLF & _
"Access: (0600/-rw-------) Uid: ( 1002/user) Gid: ( 1003/user)" & @CRLF & _
"Access: 2022-06-06 07:12:31.298324852 -0400" & @CRLF & _
"Modify: 2022-06-02 07:54:24.493383727 -0400" & @CRLF & _
"Change: 2022-06-02 07:54:43.548316545 -0400" & @CRLF & _
" Birth: 2022-06-02 07:12:31.298324852 -0400" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")