$re = '/(?:File: \'(?P<File>.*)\')\s+(?:Size: (?P<Size>[\d]+)).*(?:IO Block: [\d\s]+(?P<Type>[\w ]+))\s+.*\s+(?:Access: (?P<Permissions>\([\w\/ \-]+\)))\s+(?:Uid: \(\s*[\d\s]+\/\s*(?P<User>[\w]+)\))\s+(?:Gid: \(\s*[\d]+\/\s*(?P<Group>[\w]+)\)).*\s+.*\s+.*\s+(?:Change: (?P<Change>[\w\- \:\.]+))\s+(?:Birth: (?P<Birth>[\w\- \:\.]+))/im';
$str = ' File: \'/home/user/file.php\'
Size: 23283 Blocks: 48 IO Block: 4096 regular file
Device: 801h/2049d Inode: 967703 Links: 1
Access: (0600/-rw-------) Uid: ( 1002/user) Gid: ( 1003/user)
Access: 2022-06-06 07:12:31.298324852 -0400
Modify: 2022-06-02 07:54:24.493383727 -0400
Change: 2022-06-02 07:54:43.548316545 -0400
Birth: 2022-06-02 07:12:31.298324852 -0400
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);