using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{c\d+::(?P<value>.*?)(?:::.*)?}}";
string input = @"{{c1::tiger}} is
a kind of {{c2::animal::something movable}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}