$re = '/\{\{c\d+::(?P<value>.*?)(?:::.*)?}}/m';
$str = '{{c1::tiger}} is
a kind of {{c2::animal::something movable}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);