package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\D*(?:\d\D*){5,}$`)
var str = `123333`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}