$re = '/^\D*(?:\d\D*){5,}$/';
$str = '123333';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);