package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:00A3([0-9]+(?:\.[0-9]{1,2})?)|[0-9]+p)$`)
var str = `10.01.0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}