$re = '/^(?:00A3([0-9]+(?:\.[0-9]{1,2})?)|[0-9]+p)$/';
$str = '10.01.0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);