$re = '/[1-9][0-9]*\/[1-9][0-9]*/';
$str = '10/1
20/2
1/2
2/3
10/20
03
-
22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);