import re
regex = re.compile(r"[1-9][0-9]*\/[1-9][0-9]*")
test_str = ("10/1\n"
"20/2\n"
"1/2\n"
"2/3\n"
"10/20\n"
"03\n"
"- \n"
"22\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")