# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=^\d,\d\d$)|(?<=^\d\d,\d$)|(?<=^\d,\d$)|(?=^\d,\d$)/0/gm;t' <<< "1,12
1,1
11,1"