re = /(?=^\d,\d\d$)|(?<=^\d\d,\d$)|(?<=^\d,\d$)|(?=^\d,\d$)/m
str = '1,12
1,1
11,1'
subst = '0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result