package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a(*SKIP)(*F)|b)|(c(*SKIP)(*F)|d)`)
var str = `ab
cd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}