$re = '/(a(*SKIP)(*F)|b)|(c(*SKIP)(*F)|d)/m';
$str = 'ab
cd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);