# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[url=[^\]]*](*SKIP)(?!)|(((f|ht)tps?:\/\/)[-a-zA-Zа-яёЁА-Я()0-9@:%_+.\~#?&;\/=]+)/<a href="$1">$1<\/a>/;t' <<< "@Theareak We know this and [b][url=https://www.mcgamerzone.com/news/67/False-positive-proxy-bans-and-bot-attacks]here[/url] [/b]is an explanation, we are trying to fix this asap! https://www.mcgamerzone.com/news/67/False-positive-proxy-bans-and-bot-attacks aaa"