$re = '~\[url=[^\]]*](*SKIP)(?!)|(((f|ht)tps?://)[-a-zA-Zа-яёЁА-Я()0-9@:%_+.\~#?&;/=]+)~';
$str = '@Theareak We know this and [b][url=https://www.mcgamerzone.com/news/67/False-positive-proxy-bans-and-bot-attacks]here[/url] [/b]is an explanation, we are trying to fix this asap! https://www.mcgamerzone.com/news/67/False-positive-proxy-bans-and-bot-attacks aaa';
$subst = "<a href=\"$1\">$1</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;