#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(?:HEADER|header)>([\s\S]*?)<\/(?:HEADER|header)>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
"<body>" & @CRLF & _
"" & @CRLF & _
"<header>" & @CRLF & _
" <h1>Most important heading here</h1>" & @CRLF & _
" <h3>Less important heading here</h3>" & @CRLF & _
" <p>Some additional information here.</p>" & @CRLF & _
"</header>" & @CRLF & _
"" & @CRLF & _
"<header> <h1>Most important heading here</h1> </header>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<footer>" & @CRLF & _
" <p>Posted by: Hege Refsnes</p>" & @CRLF & _
" <p>Contact information: <a href="mailto:someone@example.com">someone@example.com</a>.</p>" & @CRLF & _
"</footer>" & @CRLF & _
"" & @CRLF & _
"<p><strong>Note:</strong> The footer tag is not supported in Internet Explorer 8 and earlier versions.</p>" & @CRLF & _
"" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")