const regex = /<(?:HEADER|header)>([\s\S]*?)<\/(?:HEADER|header)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:HEADER|header)>([\\s\\S]*?)<\\\/(?:HEADER|header)>', 'g')
const str = `<!DOCTYPE html>
<html>
<body>
<header>
<h1>Most important heading here</h1>
<h3>Less important heading here</h3>
<p>Some additional information here.</p>
</header>
<header> <h1>Most important heading here</h1> </header>
<footer>
<p>Posted by: Hege Refsnes</p>
<p>Contact information: <a href="mailto:someone@example.com">someone@example.com</a>.</p>
</footer>
<p><strong>Note:</strong> The footer tag is not supported in Internet Explorer 8 and earlier versions.</p>
</body>
</html>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}