using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[^_]*_){0}[^_]*)(*SKIP)(*F)|_";
string input = @"I like_to see_how_too";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}