package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:[^_]*_){0}[^_]*)(*SKIP)(*F)|_`)
var str = `I like_to see_how_too`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}