$re = '/^(?![ -.&,_\'":?!])(?!.*[- &_\'":]$)(?!.*[-.#@&,:?!]{2})[a-zA-Z0-9- .#@&,_\'":.?!]+$/m';
$str = 'Building 3, Level 4 - Dubai Internet City';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);