package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s,]+(.*?)=(?|{([^{}]*)}|(\w+))`)
var str = `@article{Roxas_2011, title={Social Desirability Bias in Survey Research on Sustainable Development in Small Firms: an Exploratory Analysis of Survey Mode Effect}, volume={21}, ISSN={1099-0836}, url={http://dx.doi.org/10.1002/bse.730}, DOI={10.1002/bse.730}, number={4}, journal={Business Strategy and the Environment}, publisher={Wiley}, author={Roxas, Banjo and Lindsay, Val}, year={2011}, month=sep, pages={223\xe2\x80\x93235} }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}