re = /[\s,]+(.*?)=(?|{([^{}]*)}|(\w+))/
str = '@article{Roxas_2011, title={Social Desirability Bias in Survey Research on Sustainable Development in Small Firms: an Exploratory Analysis of Survey Mode Effect}, volume={21}, ISSN={1099-0836}, url={http://dx.doi.org/10.1002/bse.730}, DOI={10.1002/bse.730}, number={4}, journal={Business Strategy and the Environment}, publisher={Wiley}, author={Roxas, Banjo and Lindsay, Val}, year={2011}, month=sep, pages={223\\xe2\\x80\\x93235} }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end