package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/:[^\/]+`)
var str = `/foo/:some_id/bar/:id`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}